Shuffle iT Forum

Dominion => Bug Reports => Interface Issues => Topic started by: EarlS on 12 October 2018, 04:00:01 AM

Title: Gaining Inn from the Trash
Post by: EarlS on 12 October 2018, 04:00:01 AM
I just had a game where I played Lurker to gain an Inn from the trash. When I wanted to select actions to shuffle into my deck, it would only allow me to select only one copy of each different action. It would not allow me to choose two or more from any stack of actions.

This was not a problem when I bought an Inn, only when I gained it from the trash via Lurker.

So I played around and it seems like this issue is specific to gaining the Inn from the trash. If I gain INN with a workshop variant, it seems to work fine, but I tried Graverobber, and it was busted too.

Confusingly, everything works fine for an Inn gained with Rogue if gaining Inn is the only available option. If there are two options to gain in the trash and you choose Inn, then you get the broken interface. I guess somehow having a choice is what's triggering the bug.

If you like, go to game #19224624 - Decision 146, from my perspective. You can discard the Secret Passage and the Copper and then play the Graverobber to see how it freezes up. Alternatively, play the Rogue to see how it doesn't freeze because there is no choice involved.

Apologies if this is a known issue. I couldn't see it in the forums anywhere.
Title: Re: Gaining Inn from the Trash
Post by: Ingix on 12 October 2018, 10:17:26 AM
Thanks for the extremely detailed problem description. It's been known that sometimes there are problems, but since it was caused by a feature introduced for Mountain Village from Renaissance, I tried to keep it out of the known bugs until Renaissance relesaes. But in the end that is a foolish idea: Maybe it will be fixed before, maybe not, but it affects players *now*, so should be in the known bugs list. Will add it promplty.