Shuffle iT Forum

Dominion => Bug Reports => Connection Problems => Topic started by: mischiefwizard on 19 December 2019, 03:13:34 AM

Title: Server connection was closed or could not be established
Post by: mischiefwizard on 19 December 2019, 03:13:34 AM
Chrome, mac

here is console content:

remote not supported on this domain
injector.js:164 sendNonRemoteStatus
foreground.js:12 [Deprecation] Element.createShadowRoot is deprecated and will be removed in M80, around February 2020. Please use Element.attachShadow instead. See https://www.chromestatus.com/features/4507242028072960 and https://developers.google.com/web/updates/2019/07/web-components-time-to-upgrade for more details.
s @ foreground.js:12
injector.js:253 tab is active
raven-3.7.0.min.js:49 0: Opening metaserver connection (metaserver.dominion-online.com:443)
connection.js:14 WebSocket connection to 'wss://metaserver.dominion-online.com/' failed: Error in connection establishment: net::ERR_CERT_AUTHORITY_INVALID
n.connect @ connection.js:14
raven-3.7.0.min.js:49 144: Metaserver connection error (id: 0, currentId: 0). Event
raven-3.7.0.min.js:49 144: Metaserver connection closed (id: 0, currentId: 0). CloseEvent
raven-3.7.0.min.js:49 144: Close event code: 1006
raven-3.7.0.min.js:49 144: Close event string: CLOSE_ABNORMAL
raven-3.7.0.min.js:49 144: Meta Connection closed; game isn't connected so resetting
injector.js:222 resigning active
Title: Re: Server connection was closed or could not be established
Post by: pablominion on 07 February 2020, 08:38:21 PM
I'm seeing about the same thing on chrome on linux. I can't even get it to show me the textboxes for user and password, even after clearing all local data according to chrome.

It works in incognito, though. Maybe chrome is hanging on to an invalid certificate? I don't see how to delete that, though.
Title: Re: Server connection was closed or could not be established
Post by: Ingix on 07 February 2020, 11:54:47 PM
Similar reports have come via discord. It seems the new Chrome version does something that flags down the certificate chain as untrustworthy. No idea why and what can be done about it and who the "culrpit" is.
Title: Re: Server connection was closed or could not be established
Post by: pablominion on 09 February 2020, 02:11:48 AM
Similar reports have come via discord. It seems the new Chrome version does something that flags down the certificate chain as untrustworthy. No idea why and what can be done about it and who the "culrpit" is.

That doesn't really explain it working in chrome incognito, does it?
Title: Re: Server connection was closed or could not be established
Post by: Ingix on 09 February 2020, 08:46:55 AM
Good catch.

I'm at a loss to understand what's going on.  :(
Title: Re: Server connection was closed or could not be established
Post by: pablominion on 10 February 2020, 08:12:31 PM
I'm at a loss to understand what's going on.  :(

Does this mean that I (we) can't expect this will be fixed? Or hopefully something less dire?
Title: Re: Server connection was closed or could not be established
Post by: Ingix on 10 February 2020, 10:00:28 PM
Maybe Stef knows more and/or over time it becomes more clear what's happening. The reports are very isolated  until now, which doesn't help finding the issue.
Title: Re: Server connection was closed or could not be established
Post by: jtill on 21 May 2020, 02:48:46 AM
 >:(  I have been having this issue for the last couple of days. I couldn't get on at all on Monday. Yesterday it finally let me on. Today, I am back to not being able to get on. Even if I go incognito and kick or kick and resign. When I kick and resign, I get the same error message. I have cleared my cache as well and still no fix.
Title: Re: Server connection was closed or could not be established
Post by: Ingix on 21 May 2020, 08:08:10 AM
Sorry to hear that, jtill.

Can you tell me what browser you are using, and on which platform (Windows, Mac, Linux, Android, iPad)?
Title: Re: Server connection was closed or could not be established
Post by: CyanMagus on 30 May 2020, 06:35:59 PM
Hi, my girlfriend had this problem and I wanted to let you know what it was and how I solved it.

The issue is that dominion.games' SSL certificate is uses USERTrust RSA Certification Authority as a root certificate authority, and USERTrust is not trusted as a root certificate by old versions of Mac OS. Might also be a problem in Ubuntu. It's not a browser problem and clearing the cache or even switching browsers won't help.

If you're a Mac user and you're encountering this problem, updating to a newer version of macOS (Sierra or later) should solve the issue.

You can also fix the issue on a Mac without updating. Here's what I did:


This should solve the problem.