Login  |  Register

Author Topic: Library/Gear Bug  (Read 150 times)

Offline JKRich

  • Newbie
  • *
  • Posts: 34
    • View Profile
Library/Gear Bug
« on: 28 June 2017, 06:50:44 PM »
It's hard for me to imagine that every bug hasn't been found and reported on by now, but I'm pretty sure I've found a new one. Game#4752009/Oregon turn#20 (and 22) - I set aside cards with(under!) Gear, later played Library and set aside more cards, but at the end of the turn the program didn't seem to distinguish between the two and discarded all the set aside cards and at the start of the next turn displayed Gear, but as if no cards were set aside with it.

P.S. For any newbie reading this, I checked the Card Bugs forum before posting this to see if it had been posted on before -- a good idea to keep from posting a "new bug" that's already been mentioned many times before. ;)

Offline drsteelhammer

  • Global Moderator
  • *****
  • Posts: 146
    • View Profile
Re: Library/Gear Bug
« Reply #1 on: 29 June 2017, 08:38:15 AM »
wow, well spotted.

So we finally have a way to discard treasures with Library after all...

Offline Ingix

  • Moderator
  • ***
  • Posts: 475
    • View Profile
Re: Library/Gear Bug
« Reply #2 on: 29 June 2017, 09:48:04 AM »
In light of my posting in http://forum.shuffleit.nl/index.php?topic=1881, it seems that the handling for set aside cards has some problems distinguishing between cards sources (there it was Archive + Library). I set up a game with Gear and Archive and got them in parallel (played same turn) and with one turn difference, in both cases the resolution next turn was correct.

At the moment my bet would be to look at all those cards, but start with Library.