Login  |  Register

Author Topic: Inheritance on fortress + multiple advance buys bug  (Read 136 times)

Offline E.Honda

  • Newbie
  • *
  • Posts: 36
    • View Profile
Inheritance on fortress + multiple advance buys bug
« on: 10 July 2017, 11:30:41 PM »
Today I encountered another bug, I think this one has not been reported so far as I only found one thread about inheritance using the search function in the bugs section.

In game #5052959 on my turn 14 we encountered a bug. I end my action phase with an inherited estate in hand (inheritance on fortress) and two buys. On my first buy I buy advance to trash the estate into a nobles and return it to my hand due to its fortress ability. I then try to trash it again to my second advance buy and this crashes the game.

The bug is not in the log since we undid and I bought something else with my second buy but to reproduce you can jump to decision #125 which is right after the first advance buy with the estate selected as the target. Select nobles to gain, buy advance again and select the estate again, this crashes the game. If you reconnect at that point it shows a blank (non-inherited) estate in hand and you have no way to make another move.

Offline Ingix

  • Moderator
  • ***
  • Posts: 475
    • View Profile
Re: Inheritance on fortress + multiple advance buys bug
« Reply #1 on: 11 July 2017, 03:16:42 PM »
Thanks for the detailed error report and it does seem to be a previously unknown bug. For reproduction the decision number used should be 141, as decision 125 is the previous turn with only one buy and a 'real' Fortress in hand.

I also tried in another game if omitting the Inheritance and just trying to trash the same Fortress twice for Advance was the real problem, but it's not; this scenario works without a problem.

I also tried if I could reproduce the bug in another game and I could, with an additional twist. While in the game reported by E.Honda the log doesn't say anything special about the Estate trashed for the first Advance buy, in my case it did: The Estate loses track of itself. I've appended a screenshot that also shows that the Estate in my hand was shown incorrectly as a normal Estate, not (as it should be) as a green-white Action-Victory Hybrid.

Maybe this helps to pinpoint the issue.