Login  |  Register

Author Topic: Partial Log Missing and Disabled Undo Bug Still Exists  (Read 129 times)

Offline JKRich

  • Newbie
  • *
  • Posts: 43
    • View Profile
Partial Log Missing and Disabled Undo Bug Still Exists
« on: 16 December 2017, 05:53:27 AM »
1.3.5.1 was said to have fixed the bug where occasionally part of the game log disappears and the Undo button stops working. Unfortunately it's happened to me twice since then, the last time in Game #9680445. HTH

Offline Ingix

  • Global Moderator
  • ***
  • Posts: 650
    • View Profile
Re: Partial Log Missing and Disabled Undo Bug Still Exists
« Reply #1 on: 17 December 2017, 10:31:17 PM »
Thanks for the report. At the moment I can reproduce this problem for Kingdoms with Aqueduct, which I assume is one (the only?) cause of the missing log/no undo problem.

Offline JKRich

  • Newbie
  • *
  • Posts: 43
    • View Profile
Re: Partial Log Missing and Disabled Undo Bug Still Exists
« Reply #2 on: 18 December 2017, 03:40:09 AM »
Thanks for the report. At the moment I can reproduce this problem for Kingdoms with Aqueduct, which I assume is one (the only?) cause of the missing log/no undo problem.
Nice sleuthing tying this to Aqueduct. Will let you know if I see it anywhere else.

Offline Ingix

  • Global Moderator
  • ***
  • Posts: 650
    • View Profile
Re: Partial Log Missing and Disabled Undo Bug Still Exists
« Reply #3 on: 18 December 2017, 02:12:25 PM »
The Aqueduct problem has been fixed in 1.3.7, and it most probably is the only cause (it's the only known cause) of the missing log/impossible undo situation.