Login  |  Register

Author Topic: Weird display with cost reduction + lag  (Read 149 times)

Offline AdamH

  • Hero Member
  • *****
  • Posts: 512
    • View Profile
Weird display with cost reduction + lag
« on: 21 May 2022, 03:03:24 PM »
Two issues:

1. Over the last three days I've noticed that in rated games, the game is extremely laggy. I've asked my opponents if it's on their end too and they have confirmed. For example, my opponent plays a Margrave and I draw a card, it shows up in the game log right away but it will take 3-4 seconds for that card to appear in my hand so I can click on it. The rest of the interface telling me I need to discard seemed to come up right away, just not the card itself.

2. I was playing last night and there were some very weird display issues with displaying cost reduction. My opponent played a Highway and the cards in the supply did not change cost a lot of the time. Then sometimes he would buy a Highway and THAT card in the supply showed as having the appropriate reduction but none of the other supply cards would show the cost reduction.

I did get a screenshot of this but I'm not going to share it publicly right now. We were playtesting a kingdom I'm designing for an IRL tournament I'm hosting in a couple of months where money will be on the line so I don't want this kingdom to be visible to the public until then. I could send the screenshot privately to someone but I'll need to know everyone who sees it because they'll have to be disqualified from that tournament. Idk maybe I could censor it enough to show the bug but where you can't see the kingdom?

All of this was on an HP desktop computer using the latest Google Chrome. I don't notice this in bot games but it's possible this is only an issue with the interface on human opponents' turns?

Offline dane

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: Weird display with cost reduction + lag
« Reply #1 on: 22 May 2022, 07:25:47 AM »
2. I was playing last night and there were some very weird display issues with displaying cost reduction. My opponent played a Highway and the cards in the supply did not change cost a lot of the time. Then sometimes he would buy a Highway and THAT card in the supply showed as having the appropriate reduction but none of the other supply cards would show the cost reduction.
I encountered a similar problem yesterday.  On my opponent's turns the cost of Destrier (as seen by me) was not being updated when he gained cards during his turn.  I assume that it was being properly updated for him (it certainly was for me during my turns), given that he successfully bought reduced-cost Destriers on several occasions.

I use Firefox on Ubuntu.  Like Adam I'd got the impression recently that the game was laggy, but I'd been inclined to attribute that to the age (14 years) of my Dell PC.  I probably still am inclind to attribute it to that.  My guess is that the client is now more compute-intensive than it was in the past, something that would certainly be much more noticeable on old hardware.

Offline Ingix

  • Global Moderator
  • ***
  • Posts: 3537
    • View Profile
Re: Weird display with cost reduction + lag
« Reply #2 on: 22 May 2022, 10:09:08 AM »
Thanks for the reports. I haven't seen the lag issue myself, but I'm not playing much vs. humans right now. The cost reduction not working in time is also a known problem that seems hard to pin down and is very confusing for players that are affected, I agree.