Login  |  Register

Author Topic: Connection problems  (Read 553 times)

Offline markus

  • Full Member
  • ***
  • Posts: 127
    • View Profile
Connection problems
« on: 02 January 2017, 04:44:52 pm »
Since the update to the new lobby design on the beta I'm frequently experiencing what seems connection problems during games (about once per game): the page reloads automatically and I'm at the login screen. Using kick and logging in, I can then usually continue the game. Sometimes this also happens at the end of the game instead of showing the score board.
My internet connection is fine, however, so I'm wondering what the reason is.

Just now, it happened while I was waiting for my opponent to take their turn. After logging in, I ended up in the lobby instead of the game. It was definitely less than 5 minutes, but maybe my opponent resigned while waiting for me? There should be some personal history, so that I can see what happened to a specific game.

Also, I'm not sure how the client deals with connection problems during a game. In the MF client, you got a message to let you know that something is not working. Then, you could for example restart the router, if it was really the internet connection lost. Am I returned to the login screen immediately, when there's a short connection loss, or only after some time?
I don't think that there's a way for me to tell during an opponent's turn whether they are just thinking or I have lost connection?

Offline limetime

  • Full Member
  • ***
  • Posts: 120
    • View Profile
Re: Connection problems
« Reply #1 on: 02 January 2017, 11:37:22 pm »
Are you using vpn?

Offline yed

  • Full Member
  • ***
  • Posts: 151
    • View Profile
Re: Connection problems
« Reply #2 on: 02 January 2017, 11:45:39 pm »
Or proxy server?

Offline markus

  • Full Member
  • ***
  • Posts: 127
    • View Profile
Re: Connection problems
« Reply #3 on: 03 January 2017, 01:04:19 am »
Neither.
I was also watching a stream at the same time, which worked without any troubles.

Offline markus

  • Full Member
  • ***
  • Posts: 127
    • View Profile
Re: Connection problems
« Reply #4 on: 03 January 2017, 07:26:49 pm »
Today, I played around 5 games with Chrome and I didn't experience any connection problems - only annoyance is the partly blurry text as reported elsewhere.

When I tried 1 game on Firefox, it lost connection before getting to the results screen.

So maybe the problem is browser related - or just luck.  ;D

Offline Jacob Marley

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
Re: Connection problems
« Reply #5 on: 04 January 2017, 04:37:58 am »
This afternoon I was able to play one game at work.  I tried at home and cannot even get to the lobby.  I can enter username and password, but then get the load screen endlessly.

Offline Watno

  • Global Moderator
  • *****
  • Posts: 272
    • View Profile
Re: Connection problems
« Reply #6 on: 04 January 2017, 11:07:01 am »
Your account is probably stuck in a crashed game. When logging in, click the kick&resign button appearing below after you type in your details..

Offline DG

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Connection problems
« Reply #7 on: 17 January 2017, 01:29:22 am »
I'm also getting frequent lost connection, probably once per game on average.

For whatever reason, the chat server seems more sensitive to this than the rest of the client. Sometimes if I type a message for my opponent, send it, and play some cards then the card play is recorded and the chat is lost.

Offline markus

  • Full Member
  • ***
  • Posts: 127
    • View Profile
Re: Connection problems
« Reply #8 on: 06 April 2017, 11:50:28 am »
I'm reviving this topic, because I'm back at the same location as in January and experiencing the same connection problems again with Firefox, whereas I don't seem to have any troubles with Chrome. The problems seem to be the same that DG is experiencing - he mentioned also using Firefox.

With the same laptop (Windows 10) I didn't have these problems at other places. The internet connection is fine for any other purposes.

I'm attaching the screenshot from the console. Let me know, if there's any other diagnostics that I can do to help you solve the problem - I'm here for the next 10 days.