Unable to connect after 1.3.7 update

Previous topic - Next topic


I've tried rebooting and connecting on both my Mac under Chrome and Safari, and also on iPad with Safari.  In all cases, I am unable to log in, and just get the message "Server connection was closed or could not be established".


Same for me.  "Server connection was closed or could not be established."


I am having the same problem.  Despite restarting my MacBook, Dominion will not allow a log in screen.  Help :(



I can't play either but I don't think it's tied to the update as I played quite a while after the update. I finished a game, hit the "ok" button, went to the end screen, hit ready to start again, and got a "black screen of death". Attempts to start over were unsuccessful.


I played 1.3.7 fine yesterday. Today when trying to connect, only get "Server connection was closed or cannot be reestablished".

I only got that far by turning off OCSP because I wasn't even able to connect because their OCSP server was not offering a correct response. I didn't have to do that yesterday.

That leads me to believe they have infrastructure problem on their side. Thought I would find a generic "Our site is down" post from the moderators but haven't.


I hope they're not sleeping.  This happened once before and those of us that like playing around this time were just stuck for many hours because the folks in charge were sleeping.  Different time zones.

Mr. Fun Socks

Same for me: "Server connection was closed or could not be established."


Same. Wonder if anyone is able to connect, or if the server is just down


I can't get in either ... same message as everyone else: server connection was closed or could not be established. Help!



It doesn't seem to have much to do with the 1.3.7 update, because everything was working just fine.  I was already signed in I think.  I can't remember for sure, but I have played today.  For some reason I went to reload the page, because something wasn't working right and now I consistently get Server Connection was closed and could not be established.  I can't even get to the sign-in page.  I have tried kick, kick and resign, restarting my computer and anything else that I can think of and nothing works.  i am just stuck.  Please fix this.

Madam Kitty

I'm having the same issue. WHere are the developers to tell us what the heck is going on and whether they are working on it or not?

fairy dust

Same issue everyone is having.  What is going on???


Response from similar issue that happened in May.  This was posted at 4:30am eastern time / 1:30am pacific time (USA)

Quote from: Stef on 22 May 2017, 10:34:50 AM
Sorry people... this happened while I was asleep. So far I've been reasonably happy with the uptime but clearly something went wrong here. It's been mostly unplayable for the last ~12 hours.

I'm guessing we're in for the same kind of wait.  I don't think us posting and complaining gets anybody out of bed.... I wish it did ;)


Server connection cannot be established :(

Need to play to calm myself - I have teenagers - please fix.




sorry it was down everyone... please try again now.