SMF - Just Installed!

How to report bugs

Previous topic - Next topic


If you discovered a bug, please describe it in this forum.

Please always include the game number and server.
It's in green in the chat when the game starts, e.g.
"Joining game #62 on frankfurt-test."

If the bug is about the interface, please also include what browser you're using, what computer system, and depending on the nature of the bug maybe a screenshot can help. We don't need this information when it's about cards, card interactions or the game log.


I've made Child Boards for every known bug and put all the yet-found bugs there. In future, please, post your bugs in the board you will find appropriate for it. If you don't know to what board your bug is referred to, don't worry. Post it in "Other bugs" and someone will figure out where to put it.


Bug Report - Prince plus Farmer's Market

Farmer's Market set aside, but did not function entire game.

Game #6917782 Oregon.



Quote from: Wavyhill on 16 September 2017, 05:33:45 PM

Farmer's Market set aside, but did not function entire game.


Farmer's Market trashes itself, at which point it will stop functioning because it is in the trash rather than set aside with Prince.

In general, playing Prince on any card that moves itself somewhere will lead to likely disappointing behavior.


Quarry not working on new cards game #8010223


Quarry reduces the cost of Action cards. Night cards are a different type (like Treasure cards).


When you use Lurker, the entire trash (duplicates included), displays across the screen which blocks the bottom 5 action purchases. I just lost a rated game because of this.


You can click inside the Lurker reveal window, but outside any card, to make the reveal window 'jump' between an upper and lower screen position. The lower position will cover your hand, but give free access to the supply piles, as is important in the Lurker case, as you (unfortunately) had to realize.

This feature is not widely known and currently there is no way that a player can find out about without being told.


Making Fun's client had a little red arrow in the corner of that box when this was possible. No explanation was necessary.

A feature that there is no way to know about is not a good enough workaround.


I agree. The reveal window used to be smaller, but was over the in-play area, which players seem less often to want to look at in these situations.


Please see attachment file.
#11625427 on tokyo
I play Duplicate. I can call Duplicate. The log is not good, in Japanese mode.


Thanks for the report! The changes to the japanese version seem to have a few problems that weren't caught on time.


While making game #29058645 on frankfurt, on google chrome Version 75.0.3770.142 (Official Build) (64-bit), I was unable to select the option for 0-4 or 0-3 event/landmark/projects. As you can see from the screenshot I have uploaded, I could not checkmark the black box that would allow for "none" to be an option. Typically, I will add all 4 slots to be filled by all or nothing, but now when I click on the black box it just unchecks one of the event, landmark, or project options. Looks like that slot is broken.


Thanks for the report!

It turns out the landscape selection is bugged for all slots with Chrome. But because you didn't need to click on the first two slots, you didn't notice with them.

I'll look into this.


wow!!! fast reply! Thanks for looking into this  :) 8)


March 24, 2020. Playing Dominion Online with 3 players.
Joining game #37684982 on oregon.
Joining game #37685009 on frankfurt.
In this game with two bots, Fortune Teller worked.
I just played with two friends. Fortune Teller was only attacking player #3, every time, skipping player #2 every time. This is not the correct play. It's each (and every) other player (as in all other players), not every other player. There is a bug. Wish I could recreate it with the bots.


Thanks for the report, Gollum!

Unfortunately, without a game number, it's hard to verify this report. I just played a 3 player game with Fortune Teller, and each player played it and it affected each other player, just as it is supposed to.

Could your player 2 have had a Moat, Lighthouse, Champion or similar effect that protects them?

Also note that if player 3 plays Fortune Teller and player 1 and 2 then put a Victory or Curse card on top of their respective decks, if then player 1 plays a Fortune Teller as well, player 2 will just reveal the Victory/Curse on top of their deck and put it back. So from that point of view it doesn't affect them again, but it is noted in the log anyway.

A third possibility is that if a player has no Victory cards in their deck and discard pile (maybe be they trashed all, or have them in their hand), the player reveals and discards all their deck and discard pile contents, then simply discards all without putting any card on their deck.


March 27th, we played a game of 4 and after the game ended everyone of us was kicked out of the game and had to log in again.

This happend twice this evening.

I'd like to know what went wrong and if there is a possibility to see the results.

#37969717 was the last game.


I had a similar problem roughly around German midnight.

Your game was won by SvenGoet with 27 points, followed by you and Dominionator2020 tied at 18 points and Viktor_dominion with 15 points.

You can join the general dominion discord at

There is a bot (DomBot) that can access the database and tell you about results, kingdoms of games and more, that's how I got that info. Open a message session with Dombot and type "!help" and it will list commandos.


Not necessarily a bug, but an area of confusion.

When a Swamp Hag is in play, and you have a Duplicate on your Tavern Mat, the UI will ask you if you want to call Duplicate upon gaining the Curse. The natural thing to do after buying a card is to call Duplicate, thinking that you're duplicating what you bought. But in this case, what you really want to do it NOT call Duplicate, then get immediately asked again to call it, and THEN call it.

I think the solution would be to show the card that's getting duplicated somehow. Like maybe "Call Duplicate (CARDNAME)" instead of just "Call Duplicate."

An example game where this interaction occurred was #45486705. The extra curse was gained by the player dlauk.


Good idea. Note that the button you have to press shows you the card that was gained.


When using the Overlord to play a card, but then replacing that play with a way, the card that got left there has its art permanently changed to the way's art. This occurred during game #51741949. It first occurs on turn 9, where the player "quoyle" had a card in hand with the way art on it. Furthermore, after playing one of the Zombies with a way, the card in the trash has the way art. The example game given has this as well, starting on turn 11 for the player "sshoemaker".


Thanks for the report, quoyle!

You are right, some of "Way art substitution" persists when there are special circumstances (playing a card and leaving it there) and it can be confusing. It' "only" a visual bug, I'm not sure when it will be addressed.


Reporting bug on game #58025195 on frankfurt.

Sleigh and devil's workshop had an unanticipated reaction where instead of gaining devil's workshop to hand, player looked at discard and selected a card from there. See image attached.


That's not a bug, that's how the process looks from the other player's view. Due to changes in rules last year in September/October, cards in the discard pile can no longer be "lost" by having other card(s) go on top of them. Instead you are allowed to look through your discard pile to "find" the card.

In this case, the Devil's Workshop got to your opponent's discard pile, then the Sleigh was discarded on top of it. So now your opponent can "find" the Devil's Workshop (because the Sleigh effect wants to move it) by looking through their discard pile, as it is no longer on top. The rules say if it's not on top you can look through your whole discard pile.

But you are only allowed to take the Devil's Workshop (and the online game makes sure of that). That it says "a card" in the log is just an artifact of how this was setup before the rules change and hasn't been changed yet.


Sometimes, when I set up a table with specific cards and then actually start the game, I get random cards instead. Haven't found a pattern - sometimes real people, sometimes a bot. Is this a bug or am I doing something wrong?


I've never seen this happen, but looks definitely like a bug.


Hi, I just had a game where my black market picture got stuck as a pig after being hit by enchantress once. Attaching picture, unfortunately exited out of the game and don't have the game number.


Yes, this is known to rarely happen with Enchantress (and the Ways).


My rating hasn't moved up or down for several days.


Thanks for the report, thecourtjester!

The rating seems to be stuck since they day before yesterday. I've notified the developer.

Your rated games are not lost, they'll be incorporated once the problem has been resolved.


For the last week or so, I've been getting some garbage graphics when playing the game.

System:  Windows 10
Browser:  Google Chrome


Well, that didn't work very well.  I can paste it in a text editor, but for some reason I can't paste it here.

Please advise.  "Computer" is not my first language. 


I guess what you had was that some cards had a "rainbow" patttern where normally their yellow frame (Treasure cards), white frame (Action cards) etc. was.

You are not the only one with this problem. Due to Chrome being constantly updated and this being done mostly invisbly to users, if a bug comes up, you don't know where it's from. A comparison showed that it only affected Chrome users, so it is very likely a bug introduced by Chrome. Further inverstigation showed that it is related to using hardware accelleration for graphics, which means it also depends on the exact graphics cards you have.

What can you do:

1) Nothing, wait until the folks at Google fix the bug. This has happened in the past with other bugs as well.

2) Turn off hardware accelleration for the graphics card in Chrome. A step to step guide can be found at this website. I can understand that it may feel intimidating, so only do that if you are comfortable with that.

3) Use a not Chrome based browser, like Firefox, to play Dominion until the bug in Chrome is fixed. Since you are using Windows 10, you can also try Microsoft Edge.


Joining game #98154774 on tokyo.

Toward the end of the game, probably my second or third to last turn, I trashed a Bishop with another Bishop.  The two VP's that should have been awarded for trashing the Bishop were not awarded.

Replaying the same table on a new game:  Joining game #98156893 on ohio.

Game says:  "Turn 4 - louled l plays a Bishop. l gets +$1. l gets 1 VP. l trashes an Estate. l gets 1 VP."

  What actually happened: when the Estate was trashed, my VP counter incremented 1, but score did not.

Game says:  "Turn 8 - louled l plays a Fortress. l draws a Bishop. l gets +2 Actions. l plays a Bishop. l gets +$1. l gets 1 VP. l trashes an Estate. l gets 1 VP."

  What actually happened: when the Estate was trashed, my VP counter incremented 1, but score did not.

Game says:  "Turn 9 - louled l plays a Bishop. l gets +$1. l gets 1 VP. l trashes an Estate. l gets 1 VP."

    What actually happened: when the Estate was trashed, my VP counter incremented 1, but score did not.

Game says:  "Turn 13 - louled l plays a Fortress. l draws a Copper. l gets +2 Actions. l plays a Fortress. l draws a Bishop. l gets +2 Actions. l plays a Bishop. l gets +$1. l gets 1 VP. l trashes an Estate. l gets 1 VP."

    What actually happened: when the Estate was trashed, my VP counter incremented 1, but score did not.

Game says:  "Turn 14 - louled l plays a Fortress. l draws a Bishop. l gets +2 Actions. l plays a Bishop. l gets +$1. l gets 1 VP. l trashes a Bishop. l gets 2 VP."

    What actually happened: when the Bishop was trashed, my VP counter incremented 1, but score did not.


What happened is correct. When checking it seems you fell into a trap that I also fall into from time to time: A mismatch between the baseline from theoretical consideration to practical experiment.

I reloaded game 98156893 as well, turn 4. For the 3 pictures, you may need to scroll the posting horizontally, but I wanted to capture the whole state, from point totals on the left to log on the right, in one screen shot each.

Here is the baseline of the theoretcial consideration:
Before you start playing Bishop, you have 5 VP, including 0 VP token:

After you play the Bishop, but before you select what to trash, the game already executes the part that is supposed to happen before the trash, giving you +$1 and +1 VP token:

After you select the Estate to trash, the game does the rest, it gives you the additional +1VP token, but adjusts your overall VP count for the now missing Estate:

The error I am sometimes making, and which I suspect you did as well, was to disregard the first picture when actually playing, and only compare the second and third one, which does not show an increase in overall VP. Which is correct, for the time period considered, which is after you already got the the initial +1VP token from Bishop


I agree on the trashing of the Estates (one VP gain and one VP lost), however it stills seems that the game did not credit the two VP's that should have come from the trashing of the Bishop (e.g., turn 14 of game 98156893).


Bishop was the Oblisk card of the game. So trashing it also lead to a reduction of your point total by 2, offsetting the +2 VP from Bishop for trashing a $4 card.



Hi gang,

Not sure how this works. But when I make a new table, says I have "too many kingdom cards," with this kingdom in the screenshot. DO you guys know why it says that?


That problem has come up when all or almost all cards have been preselected. It's a bug, but unfortunately it's unclear what the cause is and when exactly it happens.  :(

In this case the reason is a bug that makes the client not recognize that Wizards contain a Liaison, so it doesn't complain when you leave no room for an Ally. Then the server complains with that cryptic message. This problem is fixed in a playtest version, but for now you have to add a slot that may contain an Ally.


Joining game #104273954 on ohio.

Turn 8, Lord Rattington froze after playing Swashbuckler, two Coppers and a Fortune. I have tried going back a few steps, but the same thing happens again.


Thanks for the report!

I can guess what the problem is (the Coffers received from Swashbuckler confuse it with Fortune).


I was playing a game with Bauble, and when I played the Bauble I got the prompt to choose two things ("Done Choosing" grayed out in the center of the screen with "2" highlighted) but the options didn't appear on the right side. See screen shot.

I'm using Chrome 108.0.5359.125 on Windows 10.


Yes, version 1.7. had bugs with Bauble and Desert Guids (less noticible). They have been fixed in the meantime


This is a pretty disorganized way to do things compared to GitHub issues or a report bug button in the game itself that automatically includes the game number and server in the report...

sprocket science

game #114479396

Far into the game, Lord Rattington plays a Weaver but then freezes, presumably on the decision what to gain.


Yes, Lord Rat has "I don't know what to click now" issues with a few cards, including Weaver.


Game 120062998 `League of Shopkeepers` delivers award at start of buy phase. There's nothing on the card to indicate this, and it's a problem because the +1 action would usually be more helpful in the action phase than in the buy phase. I find it unlikely that the intent of the card would be to give +1 action in the buy phase, so I'm guessing the implementation was based on thinking about the 5 favor award and neglected the 10 favor award.


League of Shopkeepers worked as it should in the game.

It gave you the 5 Favor reward (+$1) and later the additional 10 Favor reward (+1 Action, +1 Buy) after you played the Liaison (Broker). That happened during the Action phase (as Broker is an Action card).

However, with the exception of turn 11, where you could play a Kiln afterwards, you never had other Action cards in hand. That means that the game advanced immediately to the buy phase. If you had had an Action card in your hand (as in turn 11), you could have taken advantage of the +1 Action from Broker, once you had 10+ Favors.

You are generally right that the +1 Action from League of Shopkeeprs is useless if you play the Liaison during your buy phase (e.g. if it is Bauble or Contract). When cards are designed, not everything can be beneficial all of the time. That's especially true for the Favor mechanic, that is distributed among 2 kinds of cards (Liaisons and Allies), where some combinations are not as good as others.


I am unable to log in. It says game is loading, but it never does. I have tried using Bing instead of Chrome but I get the same results. It will not go beyond the log in page. The user name and password are correct, I just cannot get beyond that page.  Thank you, in advance


For some 30 minutes login didn't work :-(

The problem is gone in the mean time :-)


Hope this is the right place to report this. When bot is playing fortune, and has to choose whether to add a coin from coffers, it freezes the game.

Game 132797543 on frankfurt, but has happened several times before.

I have a screenshot if it would help.



Thanks for the report, JanS!

This is an already known bug, unfortunately not yet fixed :-(