Login button does not respond

Previous topic - Next topic


I'm running Firefox on a Mac with OS 10.14.  Everything seemed fine since the update until a game ended and the OK button wouldn't respond.  I reloaded the site and now can't log in because the log in button does nothing.  All the other buttons work, I can change to full-screen or change the language on the log-in page, but I can't log in.


This is happening to us as well. Played one game but now can't get access to the game at all.



Not only should this be fixed post-haste, but if the effective outage created by not being able to log in lasts a day or more, they should extend all our subscriptions by the length of the outage.


Same issues. I was able to play earlier today but can't login, and "kick and resign" has no effect either. Frustrating since I just subscribed yesterday :(


Please fix the access! We're jones'n over here. At least let us know you're working on the issue. Thank you


High Sparrow

I am having the same issue.  Was working about 3 hours ago, came back and now the Login button does not work


Ditto for me. I played about 3 hours ago, now can't log in. The login button doesn't work. No error, nothing. I'm on Safari on an iPad.


Is there a response to this issue somewhere?

Me too.

Chrome.  Windows 10 Desktop.


There was a problem during the European night that has been resolved now. If the problem persists for any of you, please respond again.


I am still having login issues - it is stuck on the 'Loading game...' screen


Hello. I logged in today and built a Allies game to play but after hitting the "ready" button it started loading and is still loading 3+ hours later. I tried shutting everything down and logging back in, I tried logging in with a different device, but it keeps taking me back to the loading screen. And yes, I've also tried cancel/resigning but it takes me back to "tables" screen for a half second before it goes back to dominion symbol and continues trying to load. Can you or someone force a logout for me?
User name: Amulet9


This looks to be the "Spinning Castle" problem:

You need to open a private(Firefox) or incognito (Chrome) window , go to dominion.games, enter your Name and Password, but don't click "Login". Instead, click on "Kick and Resign" (rightmost of 3 buttons below the login data area). Then you should be able to login normally (no need for private/incognito tab).
Modify message

High Sparrow

not currently able to login.  login button not responding. (chrome)


Sorry, for not responding sooner, the problem was solved by the Developer less than 10 minutes after the posting. Some server had to be restarted.