Login button does not respond

Previous topic - Next topic


Log-In tab not responding. Tried tips from previous postings without success.


Yes, unfortunately the problem from start of May seems to have occured again. It looks like it may take more than 1h before it can be resolved  :(


Login button currently not working. Currently on Chrome. Username ToastSmith. Already tried on normal tab and incognito tab, and tried the kick and kick/resign buttons as well. No effect.


It's not a problem on your end, everybody is affected (see previous posts from today in this thread).


Quote from: Ingix on 10 March 2022, 07:37:26 AM

This looks to be the "Spinning Castle" problem:

You need to open a private(Firefox) or incognito (Chrome) window , go to dominion.games, enter your Name and Password, but don't click "Login". Instead, click on "Kick and Resign" (rightmost of 3 buttons below the login data area). Then you should be able to login normally (no need for private/incognito tab).
Modify message

I tried this and Kick & Resign doesn't do anything, and I still cannot log in (Chrome). The buttons all seem unresponsive.


It's not a problem on your end, it's a affecting everyone (see previous messages in this thread from today).  Unfortunately, all you can do is wait at this time.  :(


The problem has been fixed, you play again now!


This is the second day where I have been unable to login.  The "login" button is unresponsive after I enter ID and password.  Sometimes I get a "reconnect" dialogue.  Then "Server Connection is closed".  I assumed that the system was down.  But from discord conversations that I can see, it seems that others are still playing.  Could this be a firewall problem on my end?


AFAIK this means that the connection between you and the "login server" is bad or at least not stable. As usual, that could be caused on the server end (then everybody is affected), on your end (only you are affected) or in between (some/many people are affected).

I've had this problem very rarely (when it wasn't caused by the server), but usually it was gone after a few hours, and I had no real idea why it happened. One possible thing to do is to try another browser (unlikely), another device or, if you can, another route to the internet (say using an access point that has a DSL/cable/other "line" connection to the internet, vs. a wireless one base on mobile cells.

Did you change any network configuration lately, or added a VPN or security solution (like an Anti-Virus program)?


I'm experiencing the same unresponsive login button (chrome).

Edit: It seems to be related to my internet provider - when I used 4g or a vpn, it works. Still not sure how to fix this, but I guess it's something I need to solve on my end...


Some problem here this evening, after playing some matches, seems that more people having the same issue with "cant connect"